The Modernization Experts

 

U/BL - Common Issues

Unable to administer U/BL users but able to login to U/BL

Description

This situation can arise if the machine on which U/BL is installed is upgraded, say, from Windows 2008 32-bit to Windows 2008 R2 64-bit, keeping the UBL_USERS group intact.

When U/BL 5.20 is subsequently installed, the installer displays an error saying that the UBL_USERS group could not be created.

After installation, the UBL_USERS group exists and contains all the members from the previous install, but when U/BL Administrator is launched and the authenticator is set up, the list of users is empty. It is possible to login to U/BL using an existing username but it isn't possible to use the U/BL Administrator to manage user profiles or use the U/BL Monitor to manage jobs.

Likely Cause

When the U/BL installer creates the UBL_USERS group, it also creates registry entries that are used by the U/BL Administrator to store information about user profiles. On a 64-bit Windows Server, these registry entries are stored in

HKEY_LOCAL_MACHINE \ SOFTWARE \ Wow6432Node \ Transoft \ UBL \ 2.0 \ USERS

These registry entries were not created by the installer because the UBL_USERS group already existed.

Resolution

You can  manually recreate the settings by using regedit to create:

HKEY_LOCAL_MACHINE \ SOFTWARE \ Wow6432Node \ Transoft \ UBL \ 2.0 \ USERS

Then add the user that you want to give UBL "Administrator rights"  to and create:

<USERNAME> \ Environment

You do not need to do this for all users, just the ones you want to modify using UBL Administrator.

Please contact Transoft Customer Services if this does not solve the problem.

 

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